XMind 2020 10.3.1 full version / "no patch or activation" trick

XMind 2020 10.3.1 full version / “no patch or activation” trick

Simple Steps for this trick:

  1. Download XMind from their website: https://dl3.xmind.net/XMind-2020-for-Windows-64bit-10.3.1-202101070032.exe

  2. Create a .bat file (batch file) and write these 4 lines of text:

@echo off
set VANA_LICENSE_TO=“Xmind Test”
set VANA_LICENSE_MODE=true
start “” “%~dp0\XMind.exe”

  1. Change the License Name that appears on program’s about box (optional). To do this, simply change the “Xmind Test” to something you like (preserve the quotes).

  2. Save this bat file as XmindFull.bat or any name inside the Xmind program files folder which is located here: “C:\Program Files\XMind” (assuming that you didn’t change the install location).

  3. Lastly, create a shortcut for this file in your desktop for easy access. Rename it to “XMind Full” or any title. Delete the original shortcuts found in start menu and desktop. The new shortcut is now your working version of Xmind without any patch or activation.

  4. Optional. You may change the bat file icon using the main program icon: Right click XmindFull.bat > Go to Shortcut tab > Change Icon > Browse > Put “C:\Program Files\XMind\XMind.exe” > OK
    You may pin this shortcut to your taskbar.

  5. Voila, Launch this shortcut and XMind is now activated using this trick! (see note below for Windows 64bit)

Important note on 64bit Windows:
If you are using 64bit Windows and changed the bat file icon, and having this error “Windows cannot find …”, to solve this, just prepend this text to the shortcut’s Target box including space without quotes: "%windir%\System32\cmd.exe /c "
It should appear like this: %windir%\System32\cmd.exe /c “C:\Program Files\XMind\XmindFull.bat”

Tested on latest X-Mind 2020 version 10.3.1 for Windows 10.
(Use this trick for personal use only. Happy mindmapping! :D)

—note to moderator—
disregard my previous submission, i just solved the shortcut issue on Windows 64bit. thanks

1 Like

Bro, it didn’t work. I followed your steps perfectly. It still shows “Windows cannot find…”

I did it just like you said. Please, review the batch script. I really need this app for my studies.

1 Like

It also doesn´t work for me. I get this error when launching the program through the .bat file shortcut…

Also, and for just reference, this is my .bat file…

Thoughts?

On a different but related note, assuming this little trick actually works…How will be able to notice if the app doesn´t show anything related to the license?

Cheers and be well!

@RogeM @Rj_Crz

It actually works bro! The script written here was quite distorted maybe due to copy and paste.

But my friend sent me this particular batch file which is actually the same as written as above but it seems to work perfectly.

Download it here: XMind.bat - AnonFiles

It works perfectly. Happy mindmapping! :smiley:

2 Likes

Read comment above. That will solve your problem. Have a great day!

1 Like

@Dizneei I tried using your bat file and it actually worked!

It´s weird because it seems to be the same but honestly, I don´t care, I just care it works!

Thanks to both of you guys @Dizneei @Rj_Crz

this is a very common issue, replace the " as they are not real quotes

1 Like

i thiink we have to paste batch file into the xmind APP folder then it works fine

The link don’t work, it’s impossible to download the file, can solve it?